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Microsoft ACCESS Database Basics
John Andrew, PE

Course Content

This one (1.0 PDH) Professional Development Hour course describes basic elements in

Microsoft’s, “Access” database creating software with many illustrations.

Engineering records of many types are kept for decades and should be readily retrievable
for: engineering, legal, and tax purposes. Engineering organizations keep a list of
drawings and revisions of drawings for all projects. The purchasing department keeps
records of all equipment to be purchased for each client and track the delivery dates. All
stages of manufacturing operations are planned and controlled to meet delivery
requirements including records of all product: serial numbers, bills of materials, quality

control data, and delivery dates.

A database is a computerized system for collecting, modifying, and accessing small and
large lists of similar data. A list of factory equipment: generic names, descriptions,
manufacturers, addresses, phone numbers, and prices is an example of a database. The

employee list below is another example.

_ibix
ID |Employee| First Name | Last Mame|  Address | City | Zip |[Home Phone|

I - 107 | Bill Brown 122 Apple Ave  Greenville | 20608 543-2345

] 2 102 Frank Franklyn 33, 5th Avenue Greer 20602 514-41591
3 103 Joe amith 175 Cherry 31 Mauldin | 29602 545-6732
4 104 | John Claments 222 Pear Place Greenville 29608 563-2189 |

7]
* [bern

Record: Hli" 4 k[l [kE]|oF 4
|

Create the above Microsoft Access Database Table

The rows in the above database table are called, “Records” and the items in the columns
are, “Fields”. A Field column contains one category of data such as: Item number, First
Name, Last Name, Hourly Wage, etc.

1. Open Microsoft Access > File > New > Blank Database...
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Microsoft Access
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B PHONE LIST : Database (Access 2000 file format) =10 x|

,_ﬁ Open & Desion  New | | 2

Ohjecks |E|_=J Create table in Design view

Create kable by using wizard

Tables w

Create kable by entering data

Queries \'i EIGJ
Farms \

Pick Create table by using wizard
Reports
Pages

Macros

Modules

oW gf B |

Graups

|#| Favorites

2. File name: > Phone List > Create.

3. Objects > Tables > Create table by using wizard > Enter.

Table ¥izard
Which of the sample tables listed below do wou wank ko use to create your table?
After selecting a table category, choose the sample table and sample figlds wou want to include

in wour new table, Your table can include Fields From more than one sample table. IF vou're not
sure about a field, go ahead and include it, It's easy to delete a field later,

% Business Sample Fields: Fields in my new table:
. pers,:,na| ...................... -
i Prefix _l}
Sample Tables: FirstMarne ~ |
- | MiddleMame
Mailing List Lastharme
Contacts S 1iFFise il
C bz .
uskomers Mickname o |
Employees Title
Products Organizaki
ganizakionMarme
Orders ;I Addrecs ;I Rename Field, .,
Zancel | < Back | Mexk = | Eimish

4. The, “Table Wizard” above will open with, Sample Tables and Sample Fields.

5. Under Sample Tables pick: Mailing List

6. Under Sample Fields pick: MailingListID > FirstName > LastName > MoblePhone.
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Note that wizard field names can be changed by editing and new field names, not listed in
the, “Sample Fields” list can be inserted at the top of any column.

Edit field name, “MailingListID” to read, “PHONE LISTID”.

Table Wizard

What do you wank ko name your Eable?

[pHonE LisT

(O Yes, set a primary kew For me.
. Mo, I'l set the primary ke,

Microsaoft Access uses a special kind of field, called a primary ke,

= ko uniguely identify each record in a kable. In the same way a
licernse plate number identifies a car, a primary key identifies a
| BEHEE R
2 unnounn wee record.
F o ownn oun
M HEE ORRR HEH
EREEEEEE R Do wou wank the wizard to set a primary key For you?

Cancel < Back Mext =

Einish

7. What name do you want for your table? > type, "PHONE LIST” > Next > Finish.

B PHONE LIST : Table

=101 %]

FHOME LISTID]  First Mame Last Mame | Mobile Phane

1 Bill

2 Frank

3 Joe

4 John
(AutolMumber)

Brown 043-2345
Frankliyn 514-4191

=mith 545-5732
Clernents £63-2189]

Record: 14 4 II 4 v |r|es|of 4

8. Type the First Names, Last Names, and Mobile Phone numbers as shown above. The
curser location allows editing, “Record” number 4 above.

9. Select "Design View".
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B

Field Mame | Daka Tvpe | Descripkion | 2
EHPHONE LIsTIO| AutoMurmber
Firskrarme Text
___|LastMame Texk
__|MobilePhone Texk
] =

Field Properties

General | Lookup |
Field Size Long Inkeger
Mew Yalues Increment
Formak & field name
Caption can be up ko
Indexed es (Mo Duplicates) B4
Smart Tags charackers
long,
including
spaces,
Press F1 far
help on figld
names.

10. Place mouse pointer in the cell on the left side of, “Last Name” and, “Insert” a new
field name as shown below.

Type under Field Name > Hourly Wage > Data Type > Currency, see below.

B PHONE LIST : Table =10l x|
Field Mame | Diaka Tvpe | Descripkion | «
% |PHOME LISTID Autahurmber
FirskMame Texk
LastMame Text
___|Mabil=Pharne Texk
L] hd
Field Properties

11. Place the mouse pointer on the, “X” in the top right corner above > Close > Save > Yes.
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e PHONE LIS : Database (Access 2000 fle _io/x]
Open (B Design Mew | X | 2o - i EE
Chjects #h|  Create table in Design view
1 Tables Create table by using wizard
E:j e 25| Create table by entering data
O] PHOME LIST
== Forms
3 Reports -1o/x
Y4 Pages FHONE LISTIDl First Mame | Last Mame | Hourly Wage| Mohbile Phaone
2 Macros 1/Bill Brown $10.00 |543-2345
|| 2 Frank Frankliyn #1200 514-4131
8 Modules | | 3 Joe Smith §14.00 545-6732
Groups - 4| John Clermnents $16.00 | 563-2189
R {AutoMurmber) | $0.00
Record: H|4|| 5 FIHIHEI of 5

12. The revised database, “Table” with 4 “Records” is shown above.

Import an Excel table into an Access Database
a. An Access Database Table can be: Selected > Copied > Pasted into an Excel
Spreadsheet.

b. Also an Excel Spreadsheet Table can be inserted into an Access Database.

Import a list of items from an EXCEL table file into an ACCESS table file by either of the
two methods described below.

Method-1
1. A list is a series of rows that contains related data or a series of rows that you designate
to function as a datasheet by using the, “Create List” command.

2. Format: each column has a label in the top row and contains similar facts, First Name,
Last Name, Phone Number, etc., and there are no blank rows or columns within the list.

3. To import a list of items from an EXCEL table file into an ACCESS table file: Open a
blank or existing ACCESS database > Select drop-down menu:

4. “Insert” > Table > Import Table > Browse for an Excel table file > Import > O Show
Worksheet > TABLE > Next > Next > O In a new table > Next > Field Name > Field1 >
Indexed > No >Next > O Let Access add primary key > Next Import to, Table > [ TABLE ] >
Finish.

Method-2
1. Make sure the Microsoft Excel data is in a list as described above.
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2. Close the Excel workbook that contains the data you want to use in Microsoft Access.
3. In Access, open the database that you want to insert the above Excel data list.

4. On the, “Access File” menu, point to, “Get External Data”, and then click Import.

5. In the Import dialog box, click Microsoft Excel in the Files of type box.

6. In the, “Look in list”, locate the file you want to import, and then double-click the file.

7. Follow the directions in the Import Spreadsheet Wizard.

Making an ACCESS Query

Access makes it possible to ask simple or complex questions concerning a database and
receive instant answers.

Asking the question, “Which company employees earn more than $12.00 per hour?” is an
example of a database query.

& PHONE LIST : Database (Access 2000 file format) -10] x|

L Open B Design  Thew | X | 2n T

Ohjecks El_;J Create table in Design wiew

Create kable by using wizard

] Tables i
__—-;I Queties E|.=J Create kable by entering data
-3 Faorms \
m i Pick Create Query by using wizard
¥4 Pages
2 Macros
Modules
Eroups

|#] Favorites

1. Pick Create Query by using wizard, as shown above.

2. Select Fields > FIRST NAME > PHONE NUMBER > HOURLY WAGE, as shown below.
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g=¢ Table1-JOHN-ANDREW Query : Select Query i =10 x|
FY
Tablel

*

FIRST NAME
LAST MAME
OB CODE

PHOME HUMEL™ |
w
| _’|_I
== s = TR ST NAME = | PHOME MNUMEER HOURLY WAGE =
Table: | Tablel-JOHM-AMDREW Tablel-J0OHM-AMDREW Tablel-J0OHM-AMDREW =
Sork:
Show:
Criteria: =10

ars -
1| | 3

3. Pick the cell, Criteria / HOURLY WAGE > type the amount > 10, as shown above.

4. Pick the ( X)) Close button in the top right corner of the, “PHONE LIST” Query and save
the file. See the illustration above.

EI PHOME LIST Query : Select Query

First Name Hourly WWage | Maobile Phane
b | S $10.00 5432345
|__|Frank $12.00 514-4191
| Joe $14.00 5456732
| |Jahn $16.00 |553-2189
* $0.00

5. Under, “Objects” pick, “Queries” and click on the query title to open the one shown
above.

Creating ACCESS Forms

ACCESS makes it convenient for the user to create attractive and useful forms for viewing
and updating data one record at a time.

The answer to the question, “Show me all the information available about employee Bill
Brown” would be found in a Form.
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& PHOME LIST : Database (Access 2000 file format)

UF0open B Design Hew | X | 2p

=101 x|

Ohiecks

Tables

s @ Create table by entering data

Forms

Pages

Macros

BoW g 8 W

Modules

Graups

(%] Favorites

Reports
\ Pick Create Form by using wizard

Pick, “Forms” and follow the steps in the above, “Wizard” to create the Form format

shown below.

B Table1-JOHN-ANDREWL _ =101.x|

4 FIRST MAME |EiII

LAST MAKME IEn:uwn

JOB CODE I 15

PHOME HUMBER |444-5555

HOLRLY wAGE | $15.00

Recard: HI A II 1 IHIF*I af 5

The form for record number 1 of 5 is shown above.

JOB CODE

_loix
2

FIRST MAME
LAST HAME

FHOME MUMEER
HOLRLY WAGE

Record: HI 1 II 3k |H|H9| af 5

=

|J anes

| 12
[555-666E
| $18.00
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The form for record number 3 of 5 is shown above.

Creating an ACCESS Report

A summary of prescribed record fields from a database may be printed in a sophisticated,
“Report”.

=101 x|

UHopen B Design  Hew | 2| 2p T

Objects EI.=J Create table in Design view
1 Tables _ :
__—-j Queties EIGJ Create kable by entering data
“= Forms
i8  Reports
¥4 Pages ™

2 Macros \ Select Create Report by using wizard

g&  Modules

Graups

|#| Favorites

Pick, “Reports” and follow the steps in the above, “Wizard” to create the Report format
shown below.

PHONE LIST

FIRST NAME LAST NAME JOE CODE PHONE NUMBER
Joe Smith 20 222-3336
Sam Spade 10 333-4444
Bill Brown 15 444-5555
Fred Jones 12 555-66E6
Frank Andrewns 12 555-7777

Combining Two Databases
Open the Access, “PHONE LIST” database created above.
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E Emplnyee Wages : Tahle =10l x|
ID hailing ListlD | First Mame | Last Name | Hourly YWage | Haorme F'hnnsj

|| 1/ Bill Brown F10.00 |543-2345

. 2 2 Frank Franklyn $12.00 514-4151

| 3 3 Joe =mith $14.00 | 545-5732

LA 4/ John Clements $16.00 563-2189|

:Eec-l;;l: LI;II 4 LILI&I af 4 LI_I 3

Add the, “Employee Addresses” database shown below.

E Employee Adresses : Table =101 x|

IC Ernplnz.ree| First Mame | Last Name| Address | City | Ip [Huma Fhone
i 107 Bill Brown 122 Apple Ave  Greenville | 29608 543-2345
| 2 102| Frank Franklyn 33, Sth Avenue  Greer 29602 514-4191
| [ 3 103 Joe Smith 175 Cherry St Mauldin | 29602 5456732
&4 104/ Jakn Clements 222 Pear Place Greerville = 29608 563-2189 |
# |1ber)
Record: 14] 4 || 2 b mfrafei 4

Create a Query that includes information from both of the above databases:

Give me a new table with each employee’s hourly wage from the first database and their
city from the second database as seen below.

il x|
[Sopen idpesion JNew X 4y - i EE
Objects @ Creske query in Design vigw
1 Tabkes @ Creske query by using wizard
| . & Employee Adresses Query
23 Forms
= kmployee Adresses (Juery : Select Query
@ Reports First Mame | Last Mame|  City | Hourly Wage
“3 Pages ! [ Browin Greemille $10.00
2 Maaos Franklyn | Greer F12.00
Smith tauldin $14.00
" Moo Clements | Greerville $16.00
GrouEs
Gl Favorites Record: 14| [ 1 v |eifes]of 4

1. Under “Objects” pick: Queries > Create Query by using wizard > Enter > Table:
Employee Addresses > Pick all fields (>>) > Pick Design View > Under, “Objects” pick
“Tables” > Drag the other table, “Employee Wages” into this Query > ( A line links the two

databases as illustrated below).
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= Employee Adresses Query : Select Query O] x|
el S 3
0
p Emplo
m '—-u.__&_—. W
Employee 1)
First MNarme Mailing ListID
Last Mame Firsk Mame
address Lask Marme
City Hourly \Wage
Zip Hame Phone
Home Phone
-
4 I I 3
Field: | rplEds s * | Last Mame Ciky Hourly ‘Wage =
Table: |Emploves Adresses Employvee Adresses Emploves Adresses Emploves Wages -
Sork:
Show:
Criceria
or: -
4| | 3

2. Remove the check mark under each item not included in the above query by clicking on
a check mark.

3. Click the “Show:” check boxes: ID, Employee, Address, Zip, Home Phone.

4. Transfer the second database, “Hourly Wage” field from the second database into the
modified first database.

5. Pick the hourly wage field and drag it down into the empty field next to, “City”.
6. Pick X at the top right to close and save changes.

7. Open the new query as shown below.

_iDix
First Name| Last Name|  City | Hourly Wvage
£+ Bill| Brown Greenville §10.00
+ Frank Franklyn  Grear §12.00
+ Joa Srnith flauldir §14.00
+ John Clements  Greenville §15.00
Record: 14| 4 || AEEEE

ACCESS Database Back-up and Recovery

It is always advisable to make a back-up copy of your database every day or more often.
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Mistakes, viruses, hardware problems, etc can destroy a database.

To back-up a database that is open, pick drop down menu:
File > Back Up Database. ( You may have to wait a few seconds for, “Back Up Database”

to open)

If the, “Live Database” you are using becomes damaged or lost, the Back-up can be
opened to recover the latest saved copy.

DISCLAIMER: The materials contained in the online course are not intended as a
representation or warranty on the part of PDHonline.org or any other person/organization
named herein. The materials are for general information only. They are not a substitute for
competent professional advice. Application of this information to a specific project should be
reviewed by a registered professional engineer. Anyone making use of the information set
forth herein does so at their own risk and assumes any and all resulting liability arising
therefrom.

This is the end of, “Microsoft ACCESS Database Basics, Course Content”.
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